Tag: Eclipse3.6.2

目次

参考情報

前提

  • 環境はWindows。

Javaのインストール。

  • jdk1.6.0_24をC:\local\opt\dev\jdk1.6.0_24にインストール。
  • jreはProgram Files以下(デフォルト)。

Eclipseのインストール

  • Eclipse IDE for Java EE Developersを選択してダウンロード。展開してフォルダをd:\opt\dev\eclipse3.6.2に移動。

日本語化

  • Pleiades - Eclipse プラグイン日本語化プラグインから安定版の pleiades_1.3.2.zip をダウンロード。
  • 展開し中身をC:\local\opt\dev\eclipse3.6.2に上書き。
  • eclipse.iniを開き末尾に以下の行を追加。
         -javaagent:plugins/jp.sourceforge.mergedoc.pleiades/pleiades.jar

設定

エンコーディングの設定

  • UTF-8にする。

フォーマッタの設定

  • タブポリシーをスペースのみにする。
  • Javadocフォーマットのチェックを外す。

コンパイラー・エラー/警告の設定

  • 総称型で未検査の総称型操作を無視。raw型の使用も無視。

プラグイン

Subclipse

  • アップデートサイトで以下のURLを指定。
    http://subclipse.tigris.org/update_1.6.x
  • すべて選択してインストール。

m2eclipse

  • アップデートサイトで以下のURLを指定。
    http://m2eclipse.sonatype.org/sites/m2e
  • Eclipse用Maven統合をチェックしてインストール。

m2eclipse Extras

  • m2eclipseからWTP統合などの機能がm2eclipse extrasとして分割されている。アップデートサイトで以下のURLを指定。
    http://m2eclipse.sonatype.org/sites/m2e-extras
  • 次のものにチェックしてインストール(あとHudsonとか Web Application Runnerとかあったのだがエラーで入らず)。
    • Maven Integration for Eclipse Extras
    • Maven Integration for Eclipse WTP
    • Maven Integration for Subclipse

mobsterユーティリティプラグイン

トラブルシューティング

Maven + WTP + m2eclipseのプロジェクトが動かなくなった

  • Eclipse 3.5.1から移行すると上記プロジェクトがエラーで動かなくなった。
  • m2eclipse extrasを入れてなかったのが原因っぽいので入れる。

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2016-04-13 (水) 16:47:07 (1101d)